Relé/ESP32/cívka na 24 V

pavel1tu
Příspěvky: 1054
Registrován: 26 říj 2017, 08:28
Reputation: 1
Bydliště: Trutnov
Kontaktovat uživatele:

Re: Relé/ESP32/cívka na 24 V

Příspěvek od pavel1tu » 12 srp 2019, 15:01

Pokud má místo a výhledově třeba uvažuje že něco přidá, proč ne ?

Ale POZOR, dost těchto modulů s relé chodí "inverzně" - LOG 0 na Arduinu je sepnuté relé, LOG 1 na Arduinu je rozepnuté relé - to je špatné, blbne to při zapnutí zařízení, relé si jakoby cvrknou. Lze to ošetřit zapojením, ale lepší je koupit ty správné, nebo jsou i s přepínatelnou logikou ....
UNO, NANO, Mikro, PRO mini, DUE
Pavel1TU

kenavf
Příspěvky: 1
Registrován: 19 srp 2019, 18:04
Reputation: 0

Re: Relé/ESP32/cívka na 24 V

Příspěvek od kenavf » 19 srp 2019, 18:28

pavel1tu píše:
12 srp 2019, 15:01
Pokud má místo a výhledově třeba uvažuje že něco přidá, proč ne ?

Ale POZOR, dost těchto modulů s relé chodí "inverzně" - LOG 0 na Arduinu je sepnuté relé, LOG 1 na Arduinu je rozepnuté relé - to je špatné, blbne to při zapnutí zařízení, relé si jakoby cvrknou. Lze to ošetřit zapojením, ale lepší je koupit ty správné, nebo jsou i s přepínatelnou logikou ....
Mám dojem že som narazil práve na také "inverzné"relé. Zaujímavé že keď som skúšal pátrať prečo musím dávať opačné povely HIGH/LOW aby to robilo to čo má, tak som na tú inverznosť nikde nenarazil, ani v Datasheetoch to nie je uvádzané. Mám tri relé od dvoch dodávateľov a vyzerá že to robia všetky. Keď pripojím vývody relé GND na mínus a VCC na +5V tak sa nedeje nič(necvakne) ale cvaká keď prívod "IMP" (resp. "CTRL" u toho druhého dodávateľa) pripojím na zem(GND). Keď ten signálový prívod pripojím na +5V tak sa nedeje nič. Keď som to skúšal v predinštalovaných príkladoch v Arduine Uno na projekte "BLINK"(blikanie LED diody na vývode D13) tak to spínalo v opačnej "fázy" ako bolo blikanie tej LED diody(relé bolo teda spínané povelom LOW).
Mám z toho dosť veľký problém, pretože relé mám zaradené do plusového prívodu napájania z oloveného akumulátora, zámer bol aby pri poklese napätia aku pod určitú hranicu, Arduino odpojilo samé seba od napájenia tým že rozpojí toto relé, aby sa chránil akumulátor pred prílišným vybitím.
Ale na rozpojenie kontaktu musím dať na relé signál HIGH, a to nefunguje pretože asi keď Arduino dá signál HIGH a relé sa má snahu rozpojiť, ale keď sa na okamih rozpojí tak vtedy asi klesne signál v Arduine na nižšie napätie a relé to považuje za LOW a znova sa zapne a zapne aj celé Arduino, a tak to cvaká.
Ak je to s tým "inverzným" relé pravda, ako sa dá identifikovať, pretože sa to aj špatne programuje("keď chcem niečo vypnúť, tak musím dať povel zapnúť")

EDIT:
Asi som našiel relé u ktorého to je aj uvedené
Ak pin IN prepojíte s GROUND, relé modul zopne
https://techfun.sk/produkt/rele-modul-1-kanal-5v/

Na tomto relé sa to dá navoliť pomocou "jumperu". https://techfun.sk/produkt/rele-modul-1 ... mperom-hl/

Odpovědět

Kdo je online

Uživatelé prohlížející si toto fórum: Žádní registrovaní uživatelé a 1 host